package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\bMyHost="xxxx"\r?\n.*?MyIp=\s*\"([^"]*)`)
var str = `blah blah blah MyHost="xxxx"
again blah blah blah MyIp= "x.x.x.x"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}