re = /\bMyHost="xxxx"\r?\n.*?MyIp=\s*\"([^"]*)/i
str = 'blah blah blah MyHost="xxxx"
again blah blah blah MyIp= "x.x.x.x"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end