import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{0,10}?(\\.)?(\\d{1,2})?$";
final String string = "123\n"
+ "12345678901\n"
+ "1234567890.00\n"
+ "111.12\n"
+ "123455\n"
+ ".90\n"
+ ".0\n"
+ ".\n"
+ ".900\n"
+ "1234567890\n"
+ "1234567890.1\n"
+ "1234567890.90\n\n"
+ "111.12\n"
+ "123455\n"
+ ".90\n"
+ ".900\n\n"
+ "1234567890.00\n"
+ "12345678901.90\n"
+ "123456789011\n"
+ "1234567890111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}