const regex = /^\d{0,10}?(\.)?(\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{0,10}?(\\.)?(\\d{1,2})?$', 'gm')
const str = `123
12345678901
1234567890.00
111.12
123455
.90
.0
.
.900
1234567890
1234567890.1
1234567890.90
111.12
123455
.90
.900
1234567890.00
12345678901.90
123456789011
1234567890111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}