re = /^\d{0,10}?(\.)?(\d{1,2})?$/m
str = '123
12345678901
1234567890.00
111.12
123455
.90
.0
.
.900
1234567890
1234567890.1
1234567890.90
111.12
123455
.90
.900
1234567890.00
12345678901.90
123456789011
1234567890111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end