using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+[,]+\n)";
string substitution = @"\n$1";
string input = @"Dear sir,
Thanks for your interest.
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}