use strict;
my $str = 'Dear sir,
Thanks for your interest.
';
my $regex = qr/^(.+[,]+\n)/p;
my $subst = '\\n$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";