import Foundation
let pattern = #"^(.+[,]+\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Dear sir,
Thanks for your interest.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)