using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+-[[:alnum:]]+-[[:alnum:]]+_[[:alnum:]]{3}_[[:alnum:]]{3,17}_[[:alnum:]]{3,17}(_[[:alnum:]\s]{3,20})?(_[[:alnum:]\s]{3,50})?$";
string input = @"12345-XX-XXXXXXXX_two_three_four_fi
12345-XX-XXXXXXXX_two_three_four
12345-XX-XXXXXXXX_two_three_fourtooloooooooong
12345-XX-XXXXXXXX_two_three_four_five
12345-XX-XXXXXXXX_two_three_four_five_six
12345-XX-XXXXXXXX_two_three_four_value five
12345-XX-XXXXXXXX_two_three_four_value five_value six
12345-XX-XXXXXXXX_two_three_four_512345678901234567890_six
12345-XX-XXXXXXXX_two_three_four_five_612345678901234567890123456789012345678901234567890
3-Abc-Def_Va2_ValueNumber3_ValueNumber4_ValueNumber5_ValueNumber6
mary had a little lamb 12345-XX-XXXXXXXX_two_three_four and it was delicious";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}