const regex = /^\d+-[[:alnum:]]+-[[:alnum:]]+_[[:alnum:]]{3}_[[:alnum:]]{3,17}_[[:alnum:]]{3,17}(_[[:alnum:]\s]{3,20})?(_[[:alnum:]\s]{3,50})?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+-[[:alnum:]]+-[[:alnum:]]+_[[:alnum:]]{3}_[[:alnum:]]{3,17}_[[:alnum:]]{3,17}(_[[:alnum:]\\s]{3,20})?(_[[:alnum:]\\s]{3,50})?$', 'mg')
const str = `12345-XX-XXXXXXXX_two_three_four_fi
12345-XX-XXXXXXXX_two_three_four
12345-XX-XXXXXXXX_two_three_fourtooloooooooong
12345-XX-XXXXXXXX_two_three_four_five
12345-XX-XXXXXXXX_two_three_four_five_six
12345-XX-XXXXXXXX_two_three_four_value five
12345-XX-XXXXXXXX_two_three_four_value five_value six
12345-XX-XXXXXXXX_two_three_four_512345678901234567890_six
12345-XX-XXXXXXXX_two_three_four_five_612345678901234567890123456789012345678901234567890
3-Abc-Def_Va2_ValueNumber3_ValueNumber4_ValueNumber5_ValueNumber6
mary had a little lamb 12345-XX-XXXXXXXX_two_three_four and it was delicious`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}