use strict;
my $str = '12345-XX-XXXXXXXX_two_three_four_fi
12345-XX-XXXXXXXX_two_three_four
12345-XX-XXXXXXXX_two_three_fourtooloooooooong
12345-XX-XXXXXXXX_two_three_four_five
12345-XX-XXXXXXXX_two_three_four_five_six
12345-XX-XXXXXXXX_two_three_four_value five
12345-XX-XXXXXXXX_two_three_four_value five_value six
12345-XX-XXXXXXXX_two_three_four_512345678901234567890_six
12345-XX-XXXXXXXX_two_three_four_five_612345678901234567890123456789012345678901234567890
3-Abc-Def_Va2_ValueNumber3_ValueNumber4_ValueNumber5_ValueNumber6
mary had a little lamb 12345-XX-XXXXXXXX_two_three_four and it was delicious';
my $regex = qr/^\d+-[[:alnum:]]+-[[:alnum:]]+_[[:alnum:]]{3}_[[:alnum:]]{3,17}_[[:alnum:]]{3,17}(_[[:alnum:]\s]{3,20})?(_[[:alnum:]\s]{3,50})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}