// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+-[[:alnum:]]+-[[:alnum:]]+_[[:alnum:]]{3}_[[:alnum:]]{3,17}_[[:alnum:]]{3,17}(_[[:alnum:]\s]{3,20})?(_[[:alnum:]\s]{3,50})?$").unwrap();
let string = "12345-XX-XXXXXXXX_two_three_four_fi
12345-XX-XXXXXXXX_two_three_four
12345-XX-XXXXXXXX_two_three_fourtooloooooooong
12345-XX-XXXXXXXX_two_three_four_five
12345-XX-XXXXXXXX_two_three_four_five_six
12345-XX-XXXXXXXX_two_three_four_value five
12345-XX-XXXXXXXX_two_three_four_value five_value six
12345-XX-XXXXXXXX_two_three_four_512345678901234567890_six
12345-XX-XXXXXXXX_two_three_four_five_612345678901234567890123456789012345678901234567890
3-Abc-Def_Va2_ValueNumber3_ValueNumber4_ValueNumber5_ValueNumber6
mary had a little lamb 12345-XX-XXXXXXXX_two_three_four and it was delicious";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}