using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[A-Za-z(\)-]+(?:\.[A-Za-z\(\)-]+)+){2,}";
string input = @"I am given a task that will require regex to find a string out of a paragraph. I need to find a string that looks something.like.this but is not limited to looking.something.like.this.also. ... this..has...multiple....periods miss.piggy.has.really.big.chubby.fingers.and.cant.use.a.regular.rotary.dial.telephone etc etc etc one.two
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}