use strict;
my $str = 'I am given a task that will require regex to find a string out of a paragraph. I need to find a string that looks something.like.this but is not limited to looking.something.like.this.also. ... this..has...multiple....periods miss.piggy.has.really.big.chubby.fingers.and.cant.use.a.regular.rotary.dial.telephone etc etc etc one.two
';
my $regex = qr/(?:[A-Za-z(\)-]+(?:\.[A-Za-z\(\)-]+)+){2,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}