import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[A-Za-z(\\)-]+(?:\\.[A-Za-z\\(\\)-]+)+){2,}";
final String string = "I am given a task that will require regex to find a string out of a paragraph. I need to find a string that looks something.like.this but is not limited to looking.something.like.this.also. ... this..has...multiple....periods miss.piggy.has.really.big.chubby.fingers.and.cant.use.a.regular.rotary.dial.telephone etc etc etc one.two\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}