package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[A-Za-z(\)-]+(?:\.[A-Za-z\(\)-]+)+){2,}`)
var str = `I am given a task that will require regex to find a string out of a paragraph. I need to find a string that looks something.like.this but is not limited to looking.something.like.this.also. ... this..has...multiple....periods miss.piggy.has.really.big.chubby.fingers.and.cant.use.a.regular.rotary.dial.telephone etc etc etc one.two
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}