import Foundation
let pattern = #"(?:[A-Za-z(\)-]+(?:\.[A-Za-z\(\)-]+)+){2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I am given a task that will require regex to find a string out of a paragraph. I need to find a string that looks something.like.this but is not limited to looking.something.like.this.also. ... this..has...multiple....periods miss.piggy.has.really.big.chubby.fingers.and.cant.use.a.regular.rotary.dial.telephone etc etc etc one.two
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)