using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(article\d{3})";
string input = @"Brand1 article924 Simple name position
Brand5 article455 Simple name position
Brand64 article963 Simple name position
Brand123 article567 Simple name position
Brand274 article731 Simple name position
Brand399 article844 Simple name position";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}