re = /(article\d{3})/m
str = 'Brand1 article924 Simple name position
Brand5 article455 Simple name position
Brand64 article963 Simple name position
Brand123 article567 Simple name position
Brand274 article731 Simple name position
Brand399 article844 Simple name position'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end