import re
regex = re.compile(r"(article\d{3})", flags=re.MULTILINE)
test_str = ("Brand1 article924 Simple name position\n"
"Brand5 article455 Simple name position\n"
"Brand64 article963 Simple name position\n"
"Brand123 article567 Simple name position\n"
"Brand274 article731 Simple name position\n"
"Brand399 article844 Simple name position")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")