// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(article\d{3})").unwrap();
let string = "Brand1 article924 Simple name position
Brand5 article455 Simple name position
Brand64 article963 Simple name position
Brand123 article567 Simple name position
Brand274 article731 Simple name position
Brand399 article844 Simple name position";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}