import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(article\\d{3})";
final String string = "Brand1 article924 Simple name position\n"
+ "Brand5 article455 Simple name position\n"
+ "Brand64 article963 Simple name position\n"
+ "Brand123 article567 Simple name position\n"
+ "Brand274 article731 Simple name position\n"
+ "Brand399 article844 Simple name position";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}