import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[a-z]+>)?+(.*?)(<\\/[a-z]+>)";
final String string = "<file>data/Herstel_olieprijs_helpt_Damrak.txt</file><title>Hervormingsplan FIFA is klaar</title><pubdate>Fri, 20 Nov 2015 19:53:48 +0100</pubdate>\n\n"
+ "<category></category>\n"
+ "<summary><p>Het grote zuiveringsplan van de wereldvoetbalbond FIFA is klaar.\n\n"
+ "(<.*>)(.*)(<\\/.*+>)\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}