const regex = /(<[a-z]+>)?+(.*?)(<\/[a-z]+>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[a-z]+>)?+(.*?)(<\\\/[a-z]+>)', '')
const str = `<file>data/Herstel_olieprijs_helpt_Damrak.txt</file><title>Hervormingsplan FIFA is klaar</title><pubdate>Fri, 20 Nov 2015 19:53:48 +0100</pubdate>
<category></category>
<summary><p>Het grote zuiveringsplan van de wereldvoetbalbond FIFA is klaar.
(<.*>)(.*)(<\\/.*+>)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}