re = /(<[a-z]+>)?+(.*?)(<\/[a-z]+>)/
str = '<file>data/Herstel_olieprijs_helpt_Damrak.txt</file><title>Hervormingsplan FIFA is klaar</title><pubdate>Fri, 20 Nov 2015 19:53:48 +0100</pubdate>
<category></category>
<summary><p>Het grote zuiveringsplan van de wereldvoetbalbond FIFA is klaar.
(<.*>)(.*)(<\\/.*+>)
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end