$re = '/(<[a-z]+>)?+(.*?)(<\/[a-z]+>)/';
$str = '<file>data/Herstel_olieprijs_helpt_Damrak.txt</file><title>Hervormingsplan FIFA is klaar</title><pubdate>Fri, 20 Nov 2015 19:53:48 +0100</pubdate>
<category></category>
<summary><p>Het grote zuiveringsplan van de wereldvoetbalbond FIFA is klaar.
(<.*>)(.*)(<\\/.*+>)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);