#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<a class="" href="/voice/m/contact/[^>]*>\K([\s\S]*?)(?=</a>)"
Local $sString = "<b>" & @CRLF & _
"" & @CRLF & _
"<a class="" href="/voice/m/contact/dhbte4tgsbhh65u6">Name</a>" & @CRLF & _
"</b>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)