$re = '~<a class="" href="/voice/m/contact/[^>]*>\K([\s\S]*?)(?=</a>)~m';
$str = '<b>
<a class="" href="/voice/m/contact/dhbte4tgsbhh65u6">Name</a>
</b>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;