using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a class="" href=""/voice/m/contact/[^>]*>\K([\s\S]*?)(?=</a>)";
string substitution = @"";
string input = @"<b>
<a class="" href=""/voice/m/contact/dhbte4tgsbhh65u6"">Name</a>
</b>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}