re = /<a class="" href="\/voice\/m\/contact\/[^>]*>\K([\s\S]*?)(?=<\/a>)/m
str = '<b>
<a class="" href="/voice/m/contact/dhbte4tgsbhh65u6">Name</a>
</b>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result