const regex = new RegExp('<a class="" href="/voice/m/contact/[^>]*>\\K([\\s\\S]*?)(?=</a>)', 'gm')
const str = `<b>
<a class="" href="/voice/m/contact/dhbte4tgsbhh65u6">Name</a>
</b>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);