#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((?:[^()]++|(?R))*\)"
Local $sString = "MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))" & @CRLF & _
"MNO(A=(B=C) D=(E=F))" & @CRLF & _
"MNO" & @CRLF & _
"RAX.MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))" & @CRLF & _
"RAX.MNO(A=(B=C) D=(E=F))" & @CRLF & _
"RAX.MNO"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")