use strict;
my $str = 'MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))
MNO(A=(B=C) D=(E=F))
MNO
RAX.MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))
RAX.MNO(A=(B=C) D=(E=F))
RAX.MNO';
my $regex = qr/\((?:[^()]++|(?R))*\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}