// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((?:[^()]++|(?R))*\)").unwrap();
let string = "MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))
MNO(A=(B=C) D=(E=F))
MNO
RAX.MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))
RAX.MNO(A=(B=C) D=(E=F))
RAX.MNO";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}