package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?:[^()]++|(?R))*\)`)
var str = `MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))
MNO(A=(B=C) D=(E=F))
MNO
RAX.MNO(A=(B=C) D=(E=F)) PQR(X=(G=H) I=(J=(K=L)))
RAX.MNO(A=(B=C) D=(E=F))
RAX.MNO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}