package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*hoge\.com(\/sp)?\/index\.html\?(.*&)?ref=camp_cat(&.*)?$`)
var str = `https://hoge.com/index.html?q=qiita&ref=camp_cat&y=2016&m=05`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}