re = /^.*hoge\.com(\/sp)?\/index\.html\?(.*&)?ref=camp_cat(&.*)?$/m
str = 'https://hoge.com/index.html?q=qiita&ref=camp_cat&y=2016&m=05'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end