$re = '/^.*hoge\.com(\/sp)?\/index\.html\?(.*&)?ref=camp_cat(&.*)?$/m';
$str = 'https://hoge.com/index.html?q=qiita&ref=camp_cat&y=2016&m=05';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);