#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x){" & @CRLF & _
" (?>" & @CRLF & _
" "(?>\\.|[^"])*"|" & @CRLF & _
" [^{}"]+|" & @CRLF & _
" (?R)" & @CRLF & _
" )*" & @CRLF & _
"}"
Local $sString = "{" & @CRLF & _
" "foo": "bar"," & @CRLF & _
" "foo": false," & @CRLF & _
" "foo": 123," & @CRLF & _
" {" & @CRLF & _
" "foo": "bar"" & @CRLF & _
" }," & @CRLF & _
" "foo": "}}}"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")