$re = '~{
(?>
"(?>\\\\.|[^"])*"|
[^{}"]+|
(?R)
)*
}~x';
$str = '{
"foo": "bar",
"foo": false,
"foo": 123,
{
"foo": "bar"
},
"foo": "}}}"
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);