package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{
(?>
"(?>\\.|[^"])*"|
[^{}"]+|
(?R)
)*
}`)
var str = `{
"foo": "bar",
"foo": false,
"foo": 123,
{
"foo": "bar"
},
"foo": "}}}"
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}