using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{
(?>
""(?>\\.|[^""])*""|
[^{}""]+|
(?R)
)*
}";
string input = @"{
""foo"": ""bar"",
""foo"": false,
""foo"": 123,
{
""foo"": ""bar""
},
""foo"": ""}}}""
}";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}