re = /{
(?>
"(?>\\.|[^"])*"|
[^{}"]+|
(?R)
)*
}/x
str = '{
"foo": "bar",
"foo": false,
"foo": 123,
{
"foo": "bar"
},
"foo": "}}}"
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end