import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{11}";
final String string = "1100582367|SDFDSFDSFDSFDSFDF\n"
+ "GBC213WREW|RWEFSDFSDF\n"
+ "1100582377|DSFDSFDSFDSF\n"
+ "2NDG.S.D\n"
+ "BIKADSFDSFDSFNO.421\n"
+ "1100582387|SDFSDFSDFDSF";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}