import Foundation
let pattern = #"^\d{11}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1100582367|SDFDSFDSFDSFDSFDF
GBC213WREW|RWEFSDFSDF
1100582377|DSFDSFDSFDSF
2NDG.S.D
BIKADSFDSFDSFNO.421
1100582387|SDFSDFSDFDSF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}