// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\d{11}").unwrap();
let string = "1100582367|SDFDSFDSFDSFDSFDF
GBC213WREW|RWEFSDFSDF
1100582377|DSFDSFDSFDSF
2NDG.S.D
BIKADSFDSFDSFNO.421
1100582387|SDFSDFSDFDSF";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}