using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\_(\d+)|\^(\d{1})|\_\{(\d+)\}|\^\{(\d+)\}";
string input = @"\int_5^{3}100x-100=10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}