package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\_(\d+)|\^(\d{1})|\_\{(\d+)\}|\^\{(\d+)\}`)
var str = `\int_5^{3}100x-100=10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}