// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\_(\d+)|\^(\d{1})|\_\{(\d+)\}|\^\{(\d+)\}").unwrap();
let string = "\\int_5^{3}100x-100=10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}