const regex = /\_(\d+)|\^(\d{1})|\_\{(\d+)\}|\^\{(\d+)\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\_(\\d+)|\\^(\\d{1})|\\_\\{(\\d+)\\}|\\^\\{(\\d+)\\}', 'g')
const str = `\\int_5^{3}100x-100=10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}